Will you create a version of the mod that works with the FAT32 file system?

No. We will not be addressing compatibility with outdated file systems. Update to NTFS.